1
Vote

TLAPM Error

description

Hello,

When I used TLA+ proof system, I met the following error:

Oops, this seems to be a bug in TLAPM.
Please give feedback to developers.


Failure("Module.Parser.parse_file")
Raised at file "pervasives.ml", line 20, characters 22-33
Called from file "m_save.ml", line 27, characters 16-20
Called from file "tlapm.ml", line 289, characters 8-112
Called from file "list.ml", line 84, characters 24-34
Called from file "tlapm.ml", line 309, characters 20-43
Called from file "tlapm.ml", line 334, characters 8-33

version == "1.4.3 (build 34695)"
built_with == "OCaml 4.01.0"
tlapm_executable == "/cygdrive/d/Java/jdk1.8.0_121/tlapm"
max_threads == 4
library_path == "/cygdrive/d/Java/lib/tlaps"
search_path == << "D:\0ICT\cygwin\usr\local\lib\tlaps\bin\"
            , "D:\0ICT\cygwin\usr\local\bin\"
            , "D:\0ICT\cygwin\usr\local\lib\tlaps\"
            , "/cygdrive/d/Java/lib/tlaps" >>
zenon == "PATH=\"${PATH}:/cygdrive/d/Java/jdk1.8.0_121:/cygdrive/d/Java/lib/tlaps/bin\"; zenon -p0 -x tla -oisar -max-time 1d \"$file\""
zenon version == "zenon version 0.7.2 [a253] 2013-03-04"
flatten_obligations == TRUE

normalize == TRUE

I want to know how to deal with it. THANK U!

comments

MartinRie wrote Apr 26 at 11:04 AM

Hello, this looks like a parser error - it might happen because of some TLA constructs like \A <<x,y>> : P(x,y) which are not supported by the TLAPS prover (a complete list of these can be found at https://tla.msr-inria.inria.fr/tlaps/content/Documentation/Unsupported_features.html ). If you like and it is possible, I can have a look at your specification and help you investigate.